Skip to main content

Bushel Inc. Security Update

Bushel Inc. is in the process of updating a key component of the security protocols on our servers and will be requiring all connections to utilize TLS (Transport Layer Security) 1.2 or greater effective March 15, 2021.

In keeping with industry security standards, Bushel Inc. servers will disallow connections from TLS 1.0 and 1.1 clients and TLS 1.2 will become the minimum TLS protocol version allowed to connect after that date. The majority of connections to our platform are already established using at least TLS 1.2, as our products and solutions utilize TLS 1.2 or greater, however access from some legacy web browsers and operating systems may be impacted.

Compatibility is a somewhat complex intersection between the operating system and app/web browser that are in use. TLS 1.2 was standardized in late 2008 and most software released within the last five years supports TLS 1.2 or above. Listed below are examples of minimum versions of platforms and web browsers that support TLS 1.2 by default. Older versions may support TLS 1.2, but that support is disabled by default.

  • Internet Explorer – Version 11 (October 2013)
  • Google Chrome – Version 29 (August 2013)
  • Microsoft Edge – All (July 2015)
  • Google Android – Version 5 (November 2014)
  • Apple iOS – Version 5 (October 2011)
  • Mozilla Firefox – Version 27 (February 2014)

For more information on TLS compatibility details regarding web browser access, please visit https://support.globalsign.com/ssl/general-ssl/tls-protocol-compatibility.

Once again, this security change will not impact Bushel Inc. applications or services and primarily impacts legacy operating systems and web browsers.

Please contact our support or customer success teams if you need assistance with determining if your company or growers connection with our platform is affected.